Titan: Software Removal (February 27, 2018)

The following modules will be removed on February 27. Please email concerns to help@olcf.ornl.gov.

Package Version
atp 1.8.3
atp 2.0.1
atp 2.0.2
cray-ccdb 2.0.1
cray-ga 5.3.0.3
cray-ga 5.3.0.4
cray-hdf5 1.8.13
cray-hdf5 1.8.14
cray-hdf5 1.8.16
cray-hdf5-parallel 1.8.13
cray-hdf5-parallel 1.8.14
cray-hdf5-parallel 1.8.16
cray-lgdb 2.4.4
cray-lgdb 2.4.5
cray-lgdb 3.0.0
cray-lgdb 3.0.2
cray-libsci 13.2.0
cray-libsci 13.3.0
cray-libsci 16.03.1
cray-mpich 7.3.0
cray-mpich 7.3.3
cray-mpich 7.4.0
cray-mpich 7.5.1
cray-mpich-abi 7.2.4
cray-mpich-abi 7.2.5
cray-mpich-abi 7.3.0
cray-mpich-abi 7.3.3
cray-mpich-abi 7.4.0
cray-mpich-abi 7.5.1
cray-netcdf 3.6.2
cray-netcdf 4.3.2
cray-netcdf 4.3.3.1
cray-netcdf 4.4.0
cray-netcdf 4.4.1
cray-netcdf-hdf5parallel 4.3.2
cray-netcdf-hdf5parallel 4.3.3.1
cray-netcdf-hdf5parallel 4.4.0
cray-netcdf-hdf5parallel 4.4.1
cray-parallel-netcdf 1.5.0
cray-parallel-netcdf 1.6.1
cray-petsc 3.5.3.1
cray-petsc 3.5.3.2
cray-petsc 3.6.1.0
cray-petsc 3.6.3.0
cray-petsc 3.7.0.0
cray-petsc-64 3.5.3.1
cray-petsc-64 3.5.3.2
cray-petsc-64 3.6.1.0
cray-petsc-64 3.6.3.0
cray-petsc-64 3.7.0.0
cray-petsc-complex 3.5.3.1
cray-petsc-complex 3.5.3.2
cray-petsc-complex 3.6.1.0
cray-petsc-complex 3.6.3.0
cray-petsc-complex 3.7.0.0
cray-petsc-complex-64 3.5.3.1
cray-petsc-complex-64 3.5.3.2
cray-petsc-complex-64 3.6.1.0
cray-petsc-complex-64 3.6.3.0
cray-petsc-complex-64 3.7.0.0
cray-shmem 7.2.4
cray-shmem 7.2.5
cray-shmem 7.3.0
cray-shmem 7.3.3
cray-shmem 7.4.0
cray-shmem 7.5.1
cray-shmem 7.5.2
cray-tpsl 1.5.1
cray-tpsl 1.5.2
cray-tpsl 16.03.1
cray-tpsl 16.06.1
cray-tpsl-64 1.5.1
cray-tpsl-64 1.5.2
cray-tpsl-64 16.03.1
cray-tpsl-64 16.06.1
cray-tpsl-64 16.12.1
cray-trilinos 12.2.1.0
cray-trilinos 12.6.3.0
cray-trilinos 12.8.1.0
craype 2.4.2
craype 2.5.4
craype 2.5.5
craypkg-gen 1.2.1
craypkg-gen 1.3.2
craypkg-gen 1.3.3
craypkg-gen 1.3.4
fftw 3.3.4.5
fftw 3.3.4.6
fftw 3.3.4.7
papi 5.4.1.2
papi 5.4.1.3
papi 5.4.3.2
perftools 6.3.0
perftools 6.3.1
perftools 6.4.0
perftools 6.4.5
perftools-base 6.3.0
perftools-base 6.3.1
perftools-base 6.4.0
perftools-base 6.4.5
perftools-lite 6.3.0
perftools-lite 6.3.1
perftools-lite 6.4.0
perftools-lite 6.4.5
stat 2.1.0.1
stat 2.2.0.1
stat 2.2.0.2
cce 8.4.0
cce 8.4.6
cce 8.5.0
cce 8.5.5
cce 8.5.6
gcc 5.2.0
gcc 5.3.0
gcc 6.1.0
gcc 6.2.0
pgi 15.3.0
pgi 15.7.0
pgi 16.3.0
pgi 16.4.0
pgi 16.5.0
pgi 16.7.0
pgi 17.1.0
pgi 17.3.0
pgi 17.5.0

Titan: Default Module Changes (January 16, 2018)

The following modules are available for testing and will become the default on January 16, 2018. Please test and report any issues.

Please note: CCE/8.6.4 requires the most recent version of packages listed in this table.

Package Current Default Future Default
cce 8.5.7 8.6.4
atp 2.0.5 2.1.1
cray-fftw 3.3.4.11 3.3.6.2
cray-hdf5 1.10.0.1 1.10.0.3
cray-hdf5-parallel 1.10.0.1 1.10.0.3
cray-lgdb 3.0.5 3.0.7
cray-mpich 7.5.2 7.6.3
cray-mpich-abi 7.5.2 7.6.3
cray-netcdf 4.4.1.1 4.4.1.1.3
cray-netcdf-hdf5parallel 4.4.1.1 4.4.1.1.3
cray-parallel-netcdf 1.7.0 1.8.1.3
papi 5.5.0.2 5.5.1.3
cray-petsc 3.7.4.0 3.7.6.1
cray-petsc-64 3.7.4.0 3.7.6.1
cray-petsc-complex 3.7.4.0 3.7.6.1
perftools 6.4.5 6.5.2
perftools-base 6.4.5 6.5.2
perftools-lite 6.4.5 6.5.2
cray-shmem 7.5.2 7.6.3
stat 2.2.0.3 3.0.1.1
cray-tpsl 16.12.1 17.11.1
cray-tpsl-64 16.12.1 17.11.1
cray-trilinos 12.8.1.0 12.10.1.1
craype 2.5.9 2.5.13

Titan: New Modules Available for Testing (August 23, 2017)

The following modules are available for testing and will become the default in the near future. Please test and report any issues.

Please note: CCE/8.6.1 requires the most recent version of packages listed in this table.

Package Current Default Future Default
cce 8.5.7 8.6.1
cray-hdf5 1.10.0.1 1.10.0.3
cray-lgdb 3.0.5 3.0.7
cray-mpich 7.5.2 7.6.1
cray-netcdf 4.4.1.1 4.4.1.1.3
cray-parallel-netcdf 1.7.0 1.8.1.3
papi 5.5.0.2 5.5.1.2
cray-petsc 3.7.4.0 3.7.6.0
perftools 6.4.5 6.5.1
perftools-base 6.4.5 6.5.1
perftools-lite 6.4.5 6.5.1
stat 2.2.0.3 3.0.1.1
cray-tpsl 16.12.1 17.06.1
cray-tpsl-64 16.12.1 17.06.1
cray-trilinos 12.8.1.0 12.10.1.1
craype 2.5.9 2.5.12

Titan: Default Module Change (February 21, 2017)

The following modules became the default on February 21.

Package Current Default Future Default
atp 2.0.2 2.0.5
cray-ccdb 2.0.1 2.0.3
cray-ga 5.3.0.3 5.3.0.7
cray-hdf5 1.8.16 1.10.0.1
cray-hdf5-parallel 1.8.16 1.10.0.1
cray-lgdb 3.0.2 3.0.5
cray-libsci 16.06.01 16.11.1
cray-mpich 7.4.0 7.5.2
cray-mpich-abi 7.4.0 7.5.2
cray-netcdf 4.4.0 4.4.1.1
cray-netcdf-hdf5parallel 4.4.0 4.4.1.1
cray-petsc 3.7.0.0 3.7.4.0
cray-petsc-64 3.7.0.0 3.7.4.0
cray-petsc-complex 3.7.0.0 3.7.4.0
cray-petsc-complex-64 3.7.0.0 3.7.4.0
cray-shemem 7.4.0 7.5.2
cray-tpsl 16.06.1 16.12.1
cray-tpsl-64 16.06.1 16.12.1
cray-trillinos 12.6.3.0 12.8.1.0
craype 2.5.5 2.5.9
craypkg-gen 1.3.3 1.3.4
fftw 3.3.4.8 3.3.4.11
iobuf 2.0.6 2.0.8
papi 5.4.3.2 5.5.0.2
perftools 6.4.0 6.4.5
perftools-base 6.4.0 6.4.5
perftools-lite 6.4.0 6.4.5
pmi 5.0.9-1.0000.10911.175.4.gem 5.0.11
cce 8.5.0 8.5.7
pgi 16.5.0 16.10.0
intel 15.0.2.164 17.0.0.098
xalt 0.5.3 0.7.5
modules 3.2.10.3 3.2.10.5

Eos: Default Module Change (February 14, 2017)

The following modules are available for testing and will become the default on February 14. Please test and report any issues.

Package Current Default Future Default
atp 1.8.3 2.0.5
cray-ccdb 1.0.7 2.0.3
cray-ga 5.3.0.3 5.3.0.7
cray-hdf5 1.8.14 1.10.0.1
cray-hdf5-parallel 1.8.14 1.10.0.1
cray-lgdb 2.4.5 3.0.5
cray-libsci 13.2.0 16.11.1
cray-mpich 7.2.5 7.5.2
cray-mpich-abi 7.2.5 7.5.2
cray-netcdf 4.3.3.1 4.4.1.1
cray-netcdf-hdf5parallel 4.3.3.1 4.4.1.1
cray-parallel-netcdf 1.6.1 1.7.0
cray-petsc 3.6.1.0 3.7.4.0
cray-petsc-64 3.6.1.0 3.7.4.0
cray-petsc-complex 3.6.1.0 3.7.4.0
cray-petsc-complex-64 3.6.1.0 3.7.4.0
cray-shemem 7.2.5 7.5.2
cray-tpsl 1.5.2 16.12.1
cray-tpsl-64 1.5.2 16.12.1
cray-trillinos 11.12.1.5 12.8.1.0
craype 2.4.2 2.5.9
craypkg-gen 1.3.2 1.3.4
fftw 3.3.4.5 3.3.4.11
iobuf 2.0.5 2.0.8
java jdk1.7.0_45 jdk1.8.0_51
papi 5.4.1.2 5.5.0.2
perftools 6.3.0 6.4.5
perftools-base 6.3.0 6.4.5
perftools-lite 6.3.0 6.4.5
pmi 5.0.7-1.0000.10678.155.25.ari 5.0.11
stat 2.2.0.1 2.2.0.3
cce 8.4.0 8.5.7
gcc 4.9.0 6.3.0
pgi 15.7.0 16.10.0
intel 15.0.2.164 17.0.0.098
xalt 0.5.3 0.7.5
modules 3.2.10.3 3.2.10.5

DTN: Upgrade (Feb, 2017)

The Data Transfer Nodes’ hardware and operating system will be upgraded in early February 2017. Following the upgrade the following software will be available. If you require additional software, please contact OLCF User Assistance.

Package Version
bbcp 15.02.03.01.1
globus_toolkit 6.0.147
hdf5 1.10.0
hsi 5.0.2
perl 5.24.0
python 2.7.12
python 3.5.2

Eos: New Modules Available for Testing (October 19, 2016)

The following modules are available for testing and will become the default in the near future. Please test and report any issues.

Package Current Default Future Default
atp 1.8.3 2.0.2
cray-ccdb 1.0.7 2.0.1
cray-ga 5.3.0.3 5.3.0.6
cray-hdf5 1.8.14 1.8.16
cray-hdf5-parallel 1.8.14 1.8.16
cray-lgdb 2.4.5 3.0.2
cray-libsci 13.2.0 16.06.01
cray-mpich 7.2.5 7.4.0
cray-mpich-abi 7.2.5 7.4.0
cray-netcdf 4.3.3.1 4.4.0
cray-netcdf-hdf5parallel 4.3.3.1 4.4.0
cray-parallel-netcdf 1.6.1 1.7.0
cray-petsc 3.6.1.0 3.7.0.0
cray-petsc-64 3.6.1.0 3.7.0.0
cray-petsc-complex 3.6.1.0 3.7.0.0
cray-petsc-complex-64 3.6.1.0 3.7.0.0
cray-shemem 7.2.5 7.4.0
cray-tpsl 1.5.2 16.06.1
cray-tpsl-64 1.5.2 16.06.1
cray-trillinos 11.12.1.5 12.6.3.0
craype 2.4.2 2.5.5
craypkg-gen 1.3.2 1.3.3
fftw 3.3.4.5 3.3.4.8
papi 5.4.1.2 5.4.3.2
perftools 6.3.0 6.4.0
perftools-base 6.3.0 6.4.0
perftools-lite 6.3.0 6.4.0
stat 2.2.0.1 2.2.0.3
cce 8.4.0 8.5.0
gcc 4.9.0 5.3.0
pgi 15.7.0 16.5.0
intel 15.0.2.164 16.0.3.210

Titan: Default Module Change (August 16, 2016)

The following modules are available for testing and will become the default on August 16. Please test and report any issues.

Package Current Default Future Default
atp 1.8.3 2.0.2
cray-ccdb 1.0.7 2.0.1
cray-ga 5.3.0.3 5.3.0.6
cray-hdf5 1.8.14 1.8.16
cray-hdf5-parallel 1.8.14 1.8.16
cray-lgdb 2.4.5 3.0.2
cray-libsci 13.2.0 16.06.01
cray-mpich 7.2.5 7.4.0
cray-mpich-abi 7.2.5 7.4.0
cray-netcdf 4.3.3.1 4.4.0
cray-netcdf-hdf5parallel 4.3.3.1 4.4.0
cray-parallel-netcdf 1.6.1 1.7.0
cray-petsc 3.6.1.0 3.7.0.0
cray-petsc-64 3.6.1.0 3.7.0.0
cray-petsc-complex 3.6.1.0 3.7.0.0
cray-petsc-complex-64 3.6.1.0 3.7.0.0
cray-shemem 7.2.5 7.4.0
cray-tpsl 1.5.2 16.06.1
cray-tpsl-64 1.5.2 16.06.1
cray-trillinos 11.12.1.5 12.6.3.0
craype 2.4.2 2.5.5
craypkg-gen 1.3.2 1.3.3
fftw 3.3.4.5 3.3.4.8
stat 2.2.0.1 2.2.0.3
cce 8.4.0 8.5.0
gcc 4.9.0 4.9.3
pgi 15.7.0 16.5.0

Titan: Software Removal (July 31, 2016)

Package Version
atp 1.7.3
atp 1.7.5
atp 1.8.2
ccm 2.2.0-1.0401.37254.2.142
ccm 2.2.0-1.0402.46086.4.120
ccm 2.2.0-1.0502.55200.8.95
cray-ccdb 1.0.3
cray-ccdb 1.0.6
cray-ga 5.1.0.4
cray-ga 5.1.0.5
cray-ga 5.3.0.1
cray-ga 5.3.0.2
cray-hdf5 1.8.12
cray-lgdb 2.3.1
cray-lgdb 2.3.2
cray-lgdb 2.4.3
cray-libsci 12.2.0
cray-libsci 13.0.0
cray-libsci 13.0.1
cray-libsci 13.0.4
cray-libsci 13.1.0
cray-libsci_acc 3.0.1
cray-libsci_acc 3.0.2
cray-libsci_acc 3.0.3.1
cray-libsci_acc 3.1.1
cray-libsci_acc 3.1.2
cray-mpich 6.3.0
cray-mpich 7.0.0
cray-mpich 7.0.4
cray-mpich 7.1.0
cray-mpich 7.2.2
cray-mpich 7.2.3
cray-mpich 7.2.4
cray-mpich 7.2.6
cray-mpich 7.3.0
cray-mpich-abi 7.0.4
cray-mpich-abi 7.1.0
cray-mpich-abi 7.2.2
cray-mpich-abi 7.2.3
cray-mpich-abi 7.2.4
cray-mpich-abi 7.2.6
cray-mpich-abi 7.3.0
cray-mpich2 6.3.0
cray-netcdf 4.3.1
cray-netcdf-hdf5parallel 4.3.1
cray-parallel-netcdf 1.5.0
cray-parallel-netcdf 1.6.0
cray-petsc 3.4.4.0
cray-petsc 3.5.1.0
cray-petsc 3.5.3.0
cray-petsc-complex 3.4.4.0
cray-petsc-complex 3.5.1.0
cray-petsc-complex 3.5.3.0
cray-shmem 6.3.0
cray-shmem 7.0.0
cray-shmem 7.0.4
cray-shmem 7.1.0
cray-shmem 7.2.2
cray-shmem 7.2.3
cray-shmem 7.2.4
cray-shmem 7.2.6
cray-shmem 7.3.0
cray-tpsl 1.4.1
cray-tpsl 1.4.2
cray-tpsl 1.4.4
cray-tpsl 1.5.0
cray-tpsl-64 1.5.0
cray-trilinos 11.10.1.0
cray-trilinos 11.12.1.3
craype 2.2.1
craype 2.4.0
craype 2.4.1
craype 2.5.0
cudatoolkit 5.5.22-1.0502.7944.3.1
cudatoolkit 5.5.51-1.0502.9594.1.1
cudatoolkit 5.5.51-1.0502.9594.3.1
cudatoolkit 6.5.14-1.0502.9613.6.1
cudatoolkit 6.5.14-1.0502.9836.8.1
fftw 2.1.5.7
fftw 3.3.0.4
fftw 3.3.4.0
fftw 3.3.4.3
fftw 3.3.4.4
papi 5.3.0
papi 5.3.1
papi 5.4.0.1
papi 5.4.1.1
perftools 6.1.4
perftools 6.2.0
perftools 6.2.3
perftools 6.2.4
perftools 6.2.5
perftools-lite 6.1.4
perftools-lite 6.2.0
perftools-lite 6.2.3
perftools-lite 6.2.4
perftools-lite 6.2.5
xt-libsci 12.2.0
xt-libsci 13.0.0
cce 8.2.5
cce 8.3.0
cce 8.3.10
cce 8.3.12
cce 8.3.13
cce 8.3.14
cce 8.3.4
cce 8.3.9
fftw 2.1.5.7
fftw 3.3.0.4
fftw 3.3.4.0
fftw 3.3.4.3
fftw 3.3.4.4
gcc 4.6.1
gcc 4.8.1
gcc 4.9.1
gcc 4.9.2
gcc 5.1.0
intel 13.1.3.192
java jdk1.7.0_45
pgi 14.1.0
pgi 14.10.0
pgi 14.2.0
pgi 14.4.0
pgi 14.7.0
pgi 15.3.0
adios 1.4.1pre1
adios 1.6.0
adios 1.7.0
boost 1.49.0
boost 1.53.0
boost 1.54.0
capsmc 3.3.0
capsmc 3.3.1
capsmc 3.3.2
capsmc 3.3.3
capsmc 3.3.4
capsmc 3.4.0
capsmc 3.4.1
capsmc 3.4.2
capsmc 3.4.3
capsmc 3.4.4
capsmc 3.4beta-r51287
capsmc 3.4beta-r51638
capsmc 3.4beta-r52008
capsmc 3.4beta-r52606
capsmc 3.4beta-r52871
cmake 2.6.4
cmake 2.8.11.2
cmake3 3.1.0
cula-dense R15
cula-dense R16
cula-dense R16a
cula-dense R16beta
cula-dense R16beta5277
dataspaces 1.3.0
dataspaces 1.4.0
ddt 4.2.2-39105
ddt 5.0-40810
ddt 5.0.1-43242
ddt 5.1-44679
emacs 24.3
forge 6.0.3-47181
git 1.8.4.1
git 2.2.0
git 2.4.5
globus 5.2.4
gromacs 4.6.6
gromacs 5
lammps 6-Mar-15
lammps 10-Feb-15
lammps 15-May-15
lammps 15May2015_reaxc
lammps 20-Jan-15
lammps 30-Apr-15
lammps 6-Mar-15
lammps 9-Dec-14
magma 1.1
matlab 7.13
matlab 7.14
namd 2.1
namd 2.11b1
ncl 6.0.0
open64-prgenv 4.1.20
openuh 3.0.30
openuh 3.0.32
openuh 3.0.36
paraview 4.0.1
paraview 4.1.0
parmetis 4.0.2
python 2.7.3
python 3.3.0
python 3.4.3
python_cython 0.19.1
python_cython 0.19.2
python_h5py 2.1.3
python_pip 1.2.1
python_pip 6.0.8
python_setuptools 1.3
r 2.14.0
scorep 1.4.2
tau 2.21.4_openmp
tau 2.21.4_pthread
tau 2.21_openmp
tau 2.21_pthread
tau 2.22.1_openmp
tau 2.22.1_pthread
tau 2.22.2-gpu
tau 2.22.2_openmp
tau 2.22.2_pthread
tau 2.22.3-b1_openmp
tau 2.22.3-b1_pthread
tau 2.22.3-b2_openmp
tau 2.22.3-b2_pthread
vasp5 5.2
wraprun 0.2.1

Titan: Default Module Change (July 19, 2016)

The following modules are available for testing and will become the default on July 19. Please test and report any issues.

Package Current Default Future Default
cudatoolkit 7.0.28-1.0502.10280.4.1 7.5.18-1.0502.10743.2.1
cray-libsci_acc 3.0.2 16.03.1
perftools 6.3.0 6.4.0
perftools-base 6.3.0 6.4.0
perftools-lite 6.3.0 6.4.0

Eos: Cray Provided Software Removal (March 29, 2016)

Package Version
pmi 5.0.4-1.0000.10161.132.4.ari
atp 1.6.3
atp 1.7.0
atp 1.7.2
atp 1.7.3
atp 1.7.5
atp 1.8.2
cray-ccdb 1.0.2
cray-ccdb 1.0.3
cray-ccdb 1.0.6
cray-ga 5.1.0.2
cray-ga 5.1.0.4
cray-ga 5.1.0.5
cray-ga 5.3.0.1
cray-hdf5 1.8.11
cray-hdf5 1.8.12
cray-hdf5-parallel 1.8.11
cray-hdf5-parallel 1.8.12
cray-lgdb 2.2.0
cray-lgdb 2.3.0
cray-lgdb 2.3.1
cray-lgdb 2.3.2
cray-libsci 12.1.01
cray-libsci 12.2.0
cray-libsci 13.0.0
cray-libsci 13.0.1
cray-mpich 6.0.2
cray-mpich 6.3.1
cray-mpich 7.0.0
cray-mpich 7.0.4
cray-mpich 7.2.2
cray-mpich-abi 7.0.4
cray-mpich-abi 7.2.2
cray-mpich-abi 7.2.3
cray-netcdf 4.3.0
cray-netcdf 4.3.1
cray-netcdf-hdf5parallel 4.3.0
cray-netcdf-hdf5parallel 4.3.1
cray-parallel-netcdf 1.3.1.1
cray-parallel-netcdf 1.4.0
cray-parallel-netcdf 1.4.1
cray-parallel-netcdf 1.5.0
cray-petsc 3.4.2.0
cray-petsc 3.4.3.1
cray-petsc 3.4.4.0
cray-petsc 3.5.1.0
cray-petsc-complex 3.4.2.0
cray-petsc-complex 3.4.3.1
cray-petsc-complex 3.4.4.0
cray-petsc-complex 3.5.1.0
cray-shmem 6.0.2
cray-shmem 6.3.1
cray-shmem 7.0.0
cray-shmem 7.0.4
cray-shmem 7.2.2
cray-tpsl 1.3.04
cray-tpsl 1.4.0
cray-tpsl 1.4.1
cray-tpsl 1.4.2
cray-trilinos 11.10.1.0
cray-trilinos 11.4.1.0
cray-trilinos 11.6.1.0
cray-trilinos 11.8.1.0
craype 1.06
craype 2.1.1
craype 2.1.2
craype 2.2.1
cudatoolkit 5.5.22-1.0502.7944.3.1
cudatoolkit 5.5.51-1.0502.9594.1.1
cudatoolkit 6.5.14-1.0502.9836.8.1
cudatoolkit 7.0.28-1.0502.10280.4.1(default)
fftw 2.1.5.6
fftw 2.1.5.7
fftw 2.1.5.9
fftw 3.3.0.4
fftw 3.3.4.0
papi 5.1.1
papi 5.3.0
papi 5.3.1
perftools 6.1.1
perftools 6.1.4
perftools 6.2.0
perftools 6.2.4
perftools-lite 6.1.1
perftools-lite 6.1.4
perftools-lite 6.2.0
perftools-lite 6.2.4
stat 2.1.0.1
cce 8.1.9
cce 8.2.0
cce 8.2.5
cce 8.2.6
cce 8.3.0
cce 8.3.12
cce 8.3.13
cce 8.3.4
cce 8.4.1
cce 8.4.2
intel 13.1.3.192
intel 14.0.2.144
pgi 12.10.0
pgi 13.7.0
pgi 14.2.0
pgi 14.7.0
pgi 15.3.0

Eos: Default Module Change (January 26, 2016)

The following modules are available for testing and will become the default on January 26. Please test and report any issues.

Package Current Default Future Default
atp 1.8.2 1.8.3
cray-ccdb 1.0.6 1.0.7
cray-ga 5.3.0.2 5.3.0.3
cray-lgdb 2.4.3 2.4.5
cray-libsci 13.0.4 13.2.0
cray-mpich 7.2.2 7.2.5
cray-mpich-abi 7.2.2 7.2.5
cray-petsc 3.5.3.1 3.6.1.0
cray-petsc-64 3.5.3.1 3.6.1.0
cray-petsc-complex 3.5.3.1 3.6.1.0
cray-petsc-complex-64 3.5.3.1 3.6.1.0
cray-shmem 7.2.2 7.2.5
cray-tpsl 1.5.0 1.5.2
cray-tpsl-64 1.5.0 1.5.2
cray-trilinos 11.12.1.3 11.12.1.5
craype 2.4.0 2.4.2
fftw 3.3.4.3 3.3.4.5
iobuf 2.0.5 2.0.6
papi 5.4.1.1 5.4.1.2
perftools 6.2.4 6.3.0
perftools-lite 6.2.4 6.3.0
stat 2.1.0.2 2.2.0.1
cce 8.3.9 8.4.0
gcc 4.8.2 4.9.0
intel 14.0.2.144 15.0.2.164
pgi 15.3.0 15.7.0

Compatibility with gcc/4.8.2

The set of new default modules is compatible with the default version of the compiler. For GCC, this is version 4.9. To use an earlier version of GCC, the default cray-mpich and cray-libsci modules must also be swapped.

The following modules are compatible with gcc/4.8.2:

gcc/4.8.2
cray-mpich/7.2.4
cray-libsci/13.1.0

Cray-petsc/3.6.1.0

There were changes to the location of the config file between petsc/3.5* and petsc/3.6*.
User makefiles must be updated. You must change the lines:

include ${PETSC_DIR}/conf/variables
include ${PETSC_DIR}/conf/rules

to

include ${PETSC_DIR}/lib/petsc/conf/variables 
include ${PETSC_DIR}/lib/petsc/conf/rules

For further details about this change see:
http://www.mcs.anl.gov/petsc/documentation/changes/36.html

Titan: Default Module Changes (November 03, 2015)

The following default changes are scheduled to occur on Titan November 03, 2015.

Package Current Default Future Default
atp 1.8.2 1.8.3
ccm 2.2.0-1.0502.55200.8.95 2.2.1-1.0502.62540.4.51
cray-ccdb 1.0.6 1.0.7
cray-ccdb 1.0.6 1.0.7
cray-ga 5.3.0.2 5.3.0.3
cray-lgdb 2.4.3 2.4.5
cray-libsci 13.0.4 13.2.0
cray-libsci_acc 3.2.1 3.3.0
cray-mpich 7.2.2 7.2.5
cray-mpich-abi 7.2.2 7.2.5
cray-petsc 3.5.3.1 3.6.1.0
cray-petsc-64 3.5.3.1 3.6.1.0
cray-petsc-complex 3.5.3.1 3.6.1.0
cray-petsc-complex-64 3.5.3.1 3.6.1.0
cray-shmem 7.2.2 7.2.5
cray-tpsl 1.5.0 1.5.2
cray-tpsl-64 1.5.0 1.5.2
cray-trilinos 11.12.1.3 11.12.1.5
craype 2.4.0 2.4.2
cudatoolkit 6.5.14-1.0502.9613.6.1 7.0.28-1.0502.10280.4.1
fftw 3.3.4.3 3.3.4.5
iobuf 2.0.5 2.0.6
papi 5.4.1.1 5.4.1.2
perftools 6.2.4 6.3.0
perftools-lite 6.2.4 6.3.0
stat 2.1.0.1 2.2.0.1
PrgEnv-cray 5.2.40 5.2.82
PrgEnv-gnu 5.2.40 5.2.82
PrgEnv-intel 5.2.40 5.2.82
PrgEnv-pgi 5.2.40 5.2.82
cce 8.3.9 8.4.0
fftw 3.3.4.3 3.3.4.5
gcc 4.8.2 4.9.0
intel 14.0.2.144 15.0.2.164
pgi 15.3.0 15.7.0
lammps 06Mar2015 13Oct2015

Compatibility with gcc/4.8.2

The set of new default modules is compatible with the default version of the compiler. For GCC, this is version 4.9. To use an earlier version of GCC, the default cray-mpich and cray-libsci modules must also be swapped.

The following modules are compatible with gcc/4.8.2:

gcc/4.8.2
cray-mpich/7.2.4
cray-libsci/13.1.0

Cray-petsc/3.6.1.0

There were changes to the location of the config file between petsc/3.5* and petsc/3.6*.
User makefiles must be updated. You must change the lines:

include ${PETSC_DIR}/conf/variables
include ${PETSC_DIR}/conf/rules

to

include ${PETSC_DIR}/lib/petsc/conf/variables 
include ${PETSC_DIR}/lib/petsc/conf/rules

For further details about this change see:
http://www.mcs.anl.gov/petsc/documentation/changes/36.html

Titan: DDT Module Changes (September 01, 2015)

The following default changes are scheduled to occur on Titan September 01, 2015.

Package Current Default Future Default
DDT 4.2.2-39105 5.1

Titan: Default Module Changes (August 11, 2015)

The following default changes are scheduled to occur on Titan August 11, 2015.

Package Current Default Future Default
cray-ga 5.3.0.1 5.3.0.2
cray-parallel-netcdf 1.5.0 1.6.1

Eos: Default Module Changes (August 04, 2015)

The following default changes are scheduled to occur on Eos August 04, 2015.

Please note the addition of cray-parallel-netcdf and cray-ga.

Package Current Default Future Default
pgi 14.9.0 15.3.0
cray-mpich 7.0.4 7.2.2
cce 8.3.4 8.3.9
cray-ga 5.1.0.5 5.3.0.2
cray-hdf5 1.8.13 1.8.14
cray-hdf5-hdf5parallel 1.8.13 1.8.14
cray-netcdf 4.3.2 4.3.3.1
cray-netcdf-hdf5parallel 4.3.2 4.3.3.1
cray-parallel-netcdf 1.5.0 1.6.1
cray-petsc 3.5.1.0 3.5.3.1
cray-petsc-complex 3.5.1.0 3.5.3.1
fftw 3.3.4.0 3.3.4.3
cray-trilinos 11.10.1.0 11.12.1.3
cray-tpsl 1.4.2 1.5.0
cray-lbsci 13.0.1 13.0.4
atp 1.7.5 1.8.2
cray-lgdb 2.3.2 2.4.3
perftools 6.2.0 6.2.4
perftools-lite 6.2.0 6.2.4
craype 2.2.1 2.4.0
papi 5.3.1 5.4.1.1
pmi 5.0.4-1.0000.10161.132.4.ari 5.0.7-1.0000.10678.155.25.ari
cray-ccdb 1.0.3 1.0.6

Titan: Default Module Changes (July 14, 2015)

The following default changes occurred July 14, 2015.

Package Current Default Future Default
cce 8.3.4 8.3.9
pgi 14.2.0 15.3.0
cray-mpich 7.0.4 7.2.2
cray-ga 5.1.0.5 5.3.0.1
cray-hdf5 1.8.13 1.8.14
cray-hdf5-hdf5parallel 1.8.13 1.8.14
cray-netcdf 4.3.2 4.3.3.1
cray-netcdf-hdf5parallel 4.3.2 4.3.3.1
cray-petsc 3.5.1.0 3.5.3.1
cray-petsc-complex 3.5.1.0 3.5.3.1
fftw 3.3.4.0 3.3.4.3
cray-trilinos 11.10.1.0 11.12.1.3
cray-tpsl 1.4.2 1.5.0
cray-lbsci 13.0.1 13.0.4
cray-libsci_acc 3.1.1 3.1.2
atp 1.7.5 1.8.2
cray-lgdb 2.3.2 2.4.3
perftools 6.2.3 6.2.4
perftools-lite 6.2.3 6.2.4
craype 2.2.1 2.4.0
papi 5.4.0.1 5.4.1.1
pmi 5.0.5-1.0000.10300.134.8.gem 5.0.7-1.0000.10678.155.29.gem
cray-ccdb 1.0.3 1.0.6

Titan: Default Module Changes (June 23, 2015)

The following default changes are scheduled to occur June 23, 2015. CUDA will also be upgraded from 5.5 to 6.5 on June 23.

Package Current Default Future Default
cudatoolkit 5.5.51-1.0502.9594.3.1 6.5.14-1.0502.9613.6.1
cray-libsci_acc 3.0.1 3.1.1
papi 5.3.1 5.4.0.1
perftools 6.2.0 6.2.3
perftools-lite 6.2.0 6.2.3

Rhea: Default Module Changes (April 14, 2015)

The following default changes are scheduled to occur April 14, 2015.

Package Current Default Future Default
PE-intel 13.1.3 14.0.4-1.8.4
PE-pgi 13.4 14.4-1.8.4
PE-gnu 4.7.1 4.8.2-1.8.4
intel 13.1.3 14.0.4
gcc 4.7.1 4.8.2
OpenMPI 1.6.5 1.8.4

Titan: Default Module Changes (March 10, 2015)

The following default changes are scheduled to occur March 10, 2015.

NOTE REBUILD REQUIRED: Many of the new default modules (including gcc, cray-libsci, cray-petsc, cray-tpsl, and cray-trilinos) have been built against mpich/7, which is binary-incompatible with previous versions of the mpich module. Binaries should not be built using a mixture of mpich/6 and mpich/7 libraries. The cray-mpich-compat/v7 and cray-mpich-compat/v6 can be used to assist with the version changes.

Package Current Default Future Default
atp 1.7.1 1.7.5
cray-ga 5.1.0.4 5.1.0.5
cray-hdf5 1.8.12 1.8.13
cray-hdf5-parallel 1.8.12 1.8.13
cray-lgdb 2.2.3 2.3.2
cray-libsci 12.2.0 13.0.1
cray-libsci_acc 3.0.1 3.0.3.1
cray-mpich 6.3.0 7.0.4
cray-netcdf 4.3.1 4.3.2
cray-netcdf-hdf5parallel 4.3.1 4.3.2
cray-parallel-netcdf 1.3.1.1 1.5.0
cray-petsc 3.4.3.1 3.5.1.0
cray-petsc-complex 3.4.3.1 3.5.1.0
cray-shmem 6.3.0 7.0.4
cray-tpsl 1.4.0 1.4.2
cray-trilinos 11.6.1.0 11.10.1.0
fftw 3.3.0.4 3.3.4.0
gdb 7.2 7.2
papi 5.3.0 5.3.1
perftools 6.1.4 6.2.0
perftools-lite 6.1.4 6.2.0
stat 2.0.0.1 2.1.0.1
xt-libsci 12.2.0 13.0.0
xt-shmem 5.6.3 5.6.3
acml 5.3.0 5.3.1
cce 8.2.5 8.3.4
chapel 1.9.0 1.10.0
fftw 3.3.0.4 3.3.4.0
gcc* 4.8.2 4.8.2
intel* 14.0.2.144 14.0.2.144
pgi* 14.2.0 14.2.0

*No change in default

Eos: Default Module Changes (Jan 20, 2015)

The following default changes are scheduled to occur Jan 20, 2015. Eos’ OS will also be upgraded on Jan 20.

NOTE REBUILD REQUIRED: Many of the new default modules (including gcc, cray-libsci, cray-petsc, cray-tpsl, and cray-trilinos) have been built against mpich/7, which is binary-incompatible with previous versions of the mpich module. Binaries should not be built using a mixture of mpich/6 and mpich/7 libraries. The cray-mpich-compat/v7 and cray-mpich-compat/v6 can be used to assist with the version changes.

Package Future Default
cray-ga 5.1.0.5
cray-hdf5 1.8.13
cray-hdf5-parallel 1.8.13
cray-lgdb 2.3.2
cray-libsci 13.0.1
cray-mpich 7.0.4
cray-netcdf 4.3.2
cray-netcdf-hdf5parallel 4.3.2
cray-parallel-netcdf 1.5.0
cray-petsc 3.5.1.0
cray-petsc-complex 3.5.1.0
cray-shmem 7.0.4
cray-tpsl 1.4.2
cray-trilinos 11.10.1.0
fftw 3.3.4.0
iobuf 2.0.5
papi 5.3.1
perftools 6.2.0
perftools-lite 6.2.0
stat 2.1.0.1
cce 8.3.4
chapel 1.10.0
gcc 4.8.2
intel 14.0.2.144
pgi 14.9.0

Titan: Cray Provided Software Removal (Early 2015)

Package Version
alps 5.2.1-20502.9041.11.6.gem
configuration 1.0-1.0401.35391.1.2.gem
configuration 1.0-1.0402.45284.1.2.gem
crprep 1.0-10401.546.1.42.gem
dmapp 3.2.11.0401.5983.4.5.gem
dmapp 4.0.11.0402.7784.4.1.gem
dvs 1.8.6_09.0-1.0401.1401.1.120
dvs 1.8.6_09.0-1.0402.1633.1.91
gni-headers 2.1-1.0401.5675.4.4.gem
gni-headers 2.1-1.0402.7541.1.5.gem
hosts 1.0-10401.35364.1.115.gem
hosts 1.0-10402.45251.1.86.gem
krca 1.0.0-20401.36792.3.70.gem
krca 1.0.0-20402.46083.4.47.gem
lbcd 2.1-1.001.35360.1.2.gem
lbcd 2.1-1.002.45245.1.2.gem
pdsh 2.26-1.401.37449.1.1.gem
pdsh 2.26-1.402.45278.1.1.gem
pmi 4.0.1-10000.9421.73.3.gem
pmi 4.0.1-10000.9753.86.3.gem
pmi 5.0.1-10000.9799.94.9.gem
pmi 5.0.2-10000.9906.117.2.gem
pmi 5.0.3-10000.9981.128.2.gem
pmi 5.0.4-10000.10161.132.18.gem
rca 1.0.0-20401.38656.2.2.gem
rca 1.0.0-20402.47290.7.1.gem
sdb 1.0-1.001.38148.4.27.gem
sdb 1.0-1.002.46896.4.18.gem
shared-root 1.0-1.0401.37253.3.50.gem
shared-root 1.0-1.0402.46893.3.17.gem
switch 1.0-10401.36779.2.72.gem
switch 1.0-10402.45840.2.63.gem
udreg 2.3.21.0401.5929.3.3.gem
udreg 2.3.21.0402.7546.1.5.gem
ugni 4.0-1.001.5928.9.5.gem
ugni 5.0-1.002.7551.1.10.gem
xpmem 0.1-20401.36790.4.3.gem
xpmem 0.1-20402.45248.1.5.gem
PrgEnv-cray 4.1.40
PrgEnv-cray 4.2.34
PrgEnv-gnu 41.40
PrgEnv-gnu 42.34
PrgEnv-intel 4.1.40
PrgEnv-intel 4.2.34
PrgEnv-pgi 41.40
PrgEnv-pgi 42.34
atp 1.6.3
atp 1.7.0
atp 1.7.1
atp 1.7.3
ccm 2.2.0-10401.37254.2.142
ccm 2.2.0-10402.46086.4.120
cray-ccdb 10.0
cray-ccdb 10.1
cray-ccdb 10.2
cray-ga 5.10
cray-ga 5.10.2
cray-ga 5.10.3
cray-hdf5 18.11
cray-hdf5-parllel 1.8.11
cray-lgdb 22.1
cray-lgdb 22.2
cray-lgdb 22.3
cray-lgdb 22.4
cray-libsci 11.1.01
cray-libsci 12.1.2
cray-libsci 12.1.3
cray-libsci 12.2.0
cray-mpich 61.1
cray-mpich 62.0
cray-mpich 62.2
cray-mpich2 5.5.5
cray-mpich2 5.6.3
cray-mpich2 6.1.1
cray-mpich2 6.2.0
cray-mpich2 6.2.2
cray-mpich2 6.3.0
cray-netcdf 4.2.1.1
cray-netcdf 4.3.0
cray-netcdf-hf5parallel 4.2.1.1
cray-netcdf-hf5parallel 4.3.0
cray-parallelnetcdf 1.3.1.1
cray-parallelnetcdf 1.4.0
cray-petsc 33.03
cray-petsc 34.3.0
cray-petsc 34.3.1
cray-petsc-coplex 3.3.03
cray-petsc-coplex 3.4.3.0
cray-petsc-coplex 3.4.3.1
cray-shmem 55.5
cray-shmem 56.3
cray-shmem 61.1
cray-shmem 62.0
cray-shmem 62.2
cray-tpsl 13.04
cray-tpsl 14.0
cray-trilinos 11.4.1.0
cray-trilinos 11.6.1.0
craype 2.1.2
craypkg-gen 1.1.0
craypkg-gen 1.1.1
cudatoolkit 5.5.20-1.0402.7700.8.1
fftw 2.1.5.5
fftw 2.1.5.6
fftw 3.3.0.2
fftw 3.3.0.3
iobuf 2.0.4
libsci_acc 21.00
libsci_acc 30.00
papi 4.3.0.1
papi 5.2.0
perftools 61.2
perftools 61.3
perftools-lit 6.1.2
perftools-lit 6.1.3
stat 1.2.1.3
stat 2.0.0.0
xt-mpich2 56.3
xt-shmem 5.63
cce 8.2.0
cce 8.2.2
cce 8.2.4
cce 8.2.5
chapel 1.8.0
chapel 1.9.0
eswrap 1.0.1
fftw 2.1.5.5
fftw 2.1.5.6
fftw 2.1.5.7
fftw 3.3.0.2
fftw 3.3.0.3
fftw 3.3.0.4
fftw 3.3.4.0
gcc 4.6.1
gcc 4.7.2
gcc 4.8.0
intel 12.1..293
moab 7.1.1
modules 3.26.6
pgi 12.5.
pgi 13.10.0
pgi 13.8.
pgi 13.9.
pgi 14.1.
torque 4.1.3snap.201210261251
torque 4.1.4
xe-sysroot 41.40
xe-sysroot 42.34
xt-asyncpe 521
xt-asyncpe 522
xt-asyncpe 523
xt-asyncpe 524
xt-asyncpe 525
xt-asyncpe 526
xt-asyncpe 52

Titan: Software Removal (Dec 09, 2014)

The following Titan software is scheduled to be removed on December 09, 2014.
If you still require a listed version, please contact help@olcf.ornl.gov.

Package Version Build
adios 0.9.13 sle4.0_pgi11.8.0
adios 1.3.1 cle4.0_gnu4.5.3_pure
adios 1.3.1 cle4.0_pgi11.8.0_s3dfix
adios 1.4.0 cle4.0_gnu4.6.2
adios 1.4.0 cle4.0_gnu4.6.2_readonly_for_matlab
adios 1.4.0 cle4.0_intel12.1.3
adios 1.4.0 cle4.0_pgi12.1.0
adios 1.4.1 sles11.1_gnu4.7.2_readonly
adios 1.5.0 chester_pgi13.6.0
adios 1.5.0 cle4.0_pgi12.10.0
boost 1.44.0 cle4.0_gnu4.5.3
boost 1.44.0 cle4.0_pathscale3.2
boost 1.44.0 cle4.0_pgi11.5.0
boost 1.53.0 cle4.0_gnu4.7.2
boost 1.53.0 cle4.0_pgi12.10.0
cdo 1.5.3 cle4.0_pgi11.10.0
cmake 2.8.6 cle4.0_gnu4.3.4
cppcheck 1.57 sles11.1_gnu4.7.2
cula-dense R13a binary
cula-dense R14 binary
dataspaces 1.0.0 cle4.0_gnu4.6.2
dataspaces 1.0.0 cle4.0_intel12.1.3
dataspaces 1.0.0 cle4.0_pgi12.1.0
dataspaces 1.1.1 sles11.1_pgi12.9
dataspaces 1.2.0 cle4.0_gnu4.7.2
dataspaces 1.2.0 cle4.0_intel12.1.3
dataspaces 1.2.0 cle4.0_pgi12.10.0
ddt 3.0-17491 sles10.1_binary
ddt 3.1-20638 sles11_binary
ddt 3.1-22442 sles11_binary
ddt 3.1-ea3 sles11_binary
ddt 3.1-rc3 sles11_binary
ddt 3.2-24924 sles11.1_binary
ddt 3.2.1-27702 sles11.1_binary
ddt 3.2.1-28503 sles11.1_binary
ddt 3.2.1 sles11.1_binary
ddt 3.2 sles11.1_binary
ddt 4.0-30663 sles11.1_binary
ddt 4.0 sles11.1_binary
ddt 4.1-32296 sles11.1_binary
ddt 4.1-32834 sles11.1_binary
dyninst 8.0-r8d98ea1-static cle4.0_gnu4.7.2
dyninst 8.0-r8d98ea1 cle4.0_gnu4.7.2
espresso 5.0.2 cle4.0_gnu4.7.2
esmf 5.2.0-p1 cle4.0_intel12.1
esmf 5.2.0-p1 cle4.0_pgi11.9.0_O
esmf 5.2.0r cle4.0_pgi11.8.0_with-lapack+netcdf4.1.2_g
esmf 5.2.0r cle4.0_pgi11.9.0_with-lapack+netcdf4.1.2_g
esmf 5.2.0r cle4.0_pgi11.9.0_with-lapack+netcdf4.1.3_O
esmf 5.2.0r cnl2.2_pgi11.0.0_with-netcdf_g
esmf 5.2.0rp1 cle4.0_cce8.0.0_O
esmf 5.2.0rp1 cle4.0_cce8.0.0_g
esmf 5.2.0rp1 cle4.0_intel12.1_O
esmf 5.2.0rp1 cle4.0_pgi11.10.0_O
esmf 5.2.0rp1 cle4.0_pgi11.10.0_with-lapack+netcdf4.1.3_O
esmf 5.2.0rp1 cle4.0_pgi12.1.0_O
esmf 5.2.0rp1 cle4.0_pgi12.4.0_O
esmf 5.2.0rp1 cle4.0_pgi12.4.0_with-lapack+netcdf4.1.3_O
esmf 5.2.0rp1 cle4.1_pgi12.8.0_O
esmf 5.2.0rp1 cle4.1_pgi12.8.0_O_with-lapack+netcdf4.1.3_O
fftw 2.1.5 cle4.0_cray7.4.3
fftw 2.1.5 cle4.0_gnu4.6.1
fftw 2.1.5 cle4.0_pgi11.8.0
fftw 3.2.2 cle4.0_gnu4.5.3
fftw 3.2.2 cle4.0_pgi11.5.0
fftw 3.2.2 sles11.1_gnu4.5.3
fftw 3.2.2 sles11.1_pgi11.5.0
fpmpi 1.2 cle4.0_papi5.0.1
fpmpi 1.2 cnl4.0_all
git 1.7.8 sles11.1_gnu4.3.4
git 1.7.9.5 sles11.1_gnu4.3.4
git 1.8.2.1 sles11.1_gnu4.3.4
glibc 2.12 cle4.0_gnu4.4.4
gperftools 2 sles11.1_gnu4.6.2
gromacs 4.5.5 cle4.0_pgi11.9.0
gsl 1.15 cle4.0_gcc4.6.2
gsl 1.15 cle4.0_gcc4.6.2_with-O3
gsl 1.15 cle4.0_gcc4.6.2_with-fast
gsl 1.15 cle4.0_gcc4.6.2_with-noopt
gsl 1.15 sles11.1_gcc4.5.3
gsl 1.15 sles11.1_intel12.1
gsl 1.15 sles11.1_intel12.1_with-debug-opt
gsl 1.15 sles11.1_pgi11.10.0
gsl 1.15 sles11.1_pgi11.10.0_with-noopt
hdf5-parallel 1.8.11 cle4.0_pgi13.7.0_fortran2003
hdf5 1.8.11 cle4.1_gnu4.7.2
hdf5 1.8.11 cle4.1_intel12.1.3.293
hdf5 1.8.11 cle4.1_pgi12.10.0
hdf5 1.8.7 cle4.0_gnu4.5.3
hdf5 1.8.7 cle4.0_pgi11.8.0
hdf5 1.8.7 cle4.0_pgi11.9.0
hdf5 1.8.7 cle4.1_gnu4.7.2-bak
hdf5 vga_1.8.7 cle4.0_gnu4.5.3
hdf5 vga_1.8.7 cle4.0_pgi11.8.0
hdf5 vga_1.8.7 cle4.0_pgi12.4.0
hdf5 vga_1.8.7 cle4.1_pgi12.5.0
hmpp-wizard-perfanalyzer 2 binary
hpctoolkit 5.1.0 sles11.1_gnu4.5.3
hpctoolkit 5.3.2 sle4.1_gnu4.7.2
hpctoolkit 5.3.2 cle4.1_gnu4.7.2_papi5.1.0.2
hpctoolkit 5.3.2 cle4.1_gnu4.7.2_papi5.1.0.2_cuda5.0.35.102
hpctoolkit snapshot-20130805 cle4.0_gnu4.7.2
hpctoolkit snapshot-20130808 cle4.1_gnu4.7.2
hypre 2.8.0b cle4.0_gnu4.6.2
hypre 2.8.0b le4.0_pgi12.1.0 2014-11-04
idl 6.4 sles_binary
idl 7.1 sl5.0_binary
lammps 14-Jun-12 cle4.0_pgi12.1.0
lammps 17-Feb-12 cle4.0_pgi12.1.0
lammps 1-Jul-11 cle4.0_gnu4.5.3
lammps 1/25/12 cle4.0_pgi11.10.0
lammps 27-Jun-12 cle4.0_pgi12.1.0
mercurial 1.9.2 sles11.1_gnu4.3.4
namd 2.7b4 cle4.0_gnu4.5.3
namd 2.8 cle4.0_gnu4.5.3
namd 2.8 cle4.0_pgi11.10.0
ncl 5.2.1 sl_binary
ncl 5.2.1 sl_gcc4.5.3
ncview 1.93g sles11.1_gcc4.6.2
ncview 1.93g sles11.1_pgi11.10.0
ncview 2.1.1 sles11.1_pgi11.10.0
netcdf 3.6.2 cle4.0_pgi11.8.0
netcdf 4.1.3 cle4.0_pgi11.8.0
netcdf 4.1.3 cle4.0_pgi11.9.0
netcdf 4.1.3 cle4.0_pgi12.4.0
netcdf 4.1.3 cle4.0_pgi12.5.0
netcdf 4.1.3 cle4.0_pgi12.5.0-bak
netcdf 4.2.1.1 cle4.1_pgi12.10.0
netcdf 4.3.0 cle4.1_pgi12.10.0
ompi 1.7.1 sles11.1_gnu4.7.2
ompi 1.7.1 sles11.1_intel12.1.3.293
ompi 1.7.1 sles11.1_pgi12.10.0
otf.bak 1.12.4salmon cle4.1_cray8.1.4
otf.bak 1.12.4salmon cle4.1_gnu4.7.2
otf.bak 1.12.4salmon cle4.1_intel12.1.3.293
otf.bak 1.12.4salmon cle4.1_pgi12.10.0
p-netcdf 1.1.1 cle4.0_pgi11.8.0
p-netcdf 1.1.1 cle4.0_pgi11.9.0
p-netcdf 1.2.0 cle4.0_intel12.1.1.256
p-netcdf 1.2.0 cle4.0_pgi11.8.0
p-netcdf 1.2.0 cle4.0_pgi11.9.0
p-netcdf 1.2.0 cle4.0_pgi12.4.0
p-netcdf 1.3.0 cle4.0_gcc4.7.0
p-netcdf 1.3.0 cle4.0_pgi11.10.0
p-netcdf 1.3.0 cle4.0_pgi12.4.0
p-netcdf 1.3.1 cle4.1_pgi11.10.0
pcre 8.32 sles11.1_gnu4.3.4
petsc-complex 3.3-debug cle4.0_gnu4.7.1
petsc-complex 3.3 cle4.0_gnu4.7.1
petsc 3.3-debug cle4.0_gnu4.7.1
petsc 3.3-debug cle4.0_gnu4.7.1_64indices
petsc 3.3 cle4.0_gnu4.7.1
petsc 3.3 cle4.0_gnu4.7.1_64indices
petsc dev cle4.2_gnu4.7.2
petsc dev test_cle4.2_gnu4.7.2
pflotran tip cle4.2_gnu4.7.2
pflotran tip test_cle4.2_gnu4.7.2
php 5.4.5 sles11.1_gnu4.3.4
pspline 1 cle4.0_cray8.0.1
pspline 1 cle4.0_gnu4.6.2
pspline 1 cle4.0_intel12.1.1.256
pspline 1 cle4.0_pgi11.10.0.patch
pspline 1 cle4.0_pgi12.1.0
pspline 1 cle4.0_pgi12.10.0
qt 4.8.5 sles11.1_gnu4.3.4
spdcp 1.0.0 cle4.0_pgi12.5.0
subversion 1.6.12 sles11.1_gnu4.5.3
subversion 1.6.17 sles11.1_gnu4.3.4
szip 2.1 sles11.1_cray7.4.0
szip 2.1 sles11.1_gnu4.5.3
szip 2.1 sles11.1_pgi11.5.0
szip 2.1 sles11.1_pgi12.4.0
vim 7.2 sles11.1_gnu4.3.4
vim 7.3 sles11.1_gnu4.3.4
vmd 1.8.7 sles11.1_binary
zlib 1.2.6 sles11.1_gnu4.3.4
zlib 1.2.6 sles11.1_pgi11.10.0
zlib 1.2.6 sles11.1_pgi12.3.0
zlib 1.2.7 gnu4.7.2
zlib 1.2.7 sles11.1_gnu4.3.4
zlib 1.2.7 sles11.1_gnu4.7.1
zlib 1.2.7 sles11.1_pgi12.8
zlib 1.2.8 sles11.1_gnu4.3.4

Rhea: New OpenMPI (Oct 10, 2014)

During the October 7 outage, OpenMPI 1.8.2 was installed on Rhea but not set as default. If you would like to try the new version, it is available through the following PE modules as well as through the openmpi/1.8.2 module.

PE-intel/14.0.2-1.8.2 PE-intel/13.1.3-1.8.2
PE-pgi/13.4-1.8.2 PE-pgi/14.4-1.8.2
PE-gnu/4.7.1-1.8.2 PE-gnu/4.8.2-1.8.2

Eos: New Software (Sep 26, 2014)

The following modules have been installed on Eos for testing. They have not been set as default but are available via the modules utility.

atp/1.7.3 cce/8.3.0 chapel/1.9.0.1
craype/2.1.2 fftw/2.1.5.7 fftw/3.3.4.0
ga/1.5.0.5 gcc/4.9.0 hdf5/1.8.13
lgdb/2.3.1 libsci/13.0.0 mpt/7.0
netcdf/4.3.2 papi/5.3.1 parallel-netcdf/1.4.1
perftools/6.2.0 petsc/3.4.4.0 pgi/14.7.0
stat/2.1.0.1 tpsl/1.4.0.1 trilinos/11.8.1.0

NOTE: The MPT 7.0 release contains ABI changes that require MPI codes to be recompiled. All libraries used for the recompile must be compatible with the new ABI. In particular, cce/8.3.0 contains significant changes from previous versions and is dependent on mpt/7.0. To assist you in changing between versions 6 and 7 of MPT, two modules have been provided:
cray-mpich-compat/v6 and cray-mpich-compat/v7.

We encourage you to begin using these modules and to report any trouble with them to help@olcf.ornl.gov.

Titan: New Defaults (Sep 16, 2014)

The following software versions were set as default on Titan on September 16. Older versions of each package remain available via modules. If you experience trouble with the new versions, please contact help@olcf.ornl.gov.

cray-netcdf/4.3.1 cray-netcdf-hdf5parallel/4.3.1 cray-hdf5/1.8.12
cray-hdf5-parallel/1.8.12 cray-petsc/3.4.3.1 cray-petsc-complex/3.4.3.1
cray-trilinos/11.6.1.0 cray-tpsl/1.4.0 papi/5.3.0
fftw/3.3.0.4 perftools/6.1.4 chapel/1.9.0
intel/14.0.2.144 pgi/14.2.0 cce/8.2.5

Titan: New Defaults (June 10, 2014)

The following software versions were set as default on Titan on June 10. If you experience trouble with the new versions, please contact help@olcf.ornl.gov.

cray-ga/5.1.0.4
xt-asyncpe/5.26
cray-mpich/6.3.0
cray-libsci/12.2.0

Note: Starting with the release of Cray LibSci 12.2.0 the CRay Adaptive FFT (CRAFFT) subroutine library for computing the discrete Fourier Transform (DFT) is no longer supported. The Cray FFTW3 library can be used instead to compute Fourier transforms.

Titan: OS Upgrade and Default Changes (Jan 28, 2014)

Titan’s OS will be upgraded to version 4.2 of CLE on Tuesday, January 28. As part of that outage, the default versions of several modules also changed.

Package From To
acml 5.2.0 5.3.1
atp 1.6.1. 1.7.1
cce 8,2,0 8.2.2
chapel 1.6.0 1.7.0.1
cray-ga 5.1.0 5.1.0.2
cray-hdf5-parallel 1.8.9 1.8.11
cray-hdf5 1.8.9 1.8.11
cray-lgdb 2.0.1 2.2.3
cray-libsci 12.0.00 12.1.3
cray-mpich 5.6.3 6.2.0
cray-mpich2 5.6.3 6.2.0
cray-petsc-complex 3.3.03 3.4.3.0
cray-petsc 3.3.03 3.4.3.0
cray-shmem 5.6.3 6.2.0
cray-tpsl 1.3.01 1.3.04
cray-trilinos 10.12.1.1 11.4.1.0
cudatoolkit 5.0.35.102 5.5.20-1
fftw 3.3.0.1 3.3.0.3
gcc 4.7.2 4.8.2
iobuf 2.0.3 2.0.5
java jdk1.7.0_07 jdk1.7.0_45
libsci_acc 2.0.00.12 3.0.00
netcdf-hdf5parallel 4.2.0 4.3.0
netcdf 4.2.0 4.3.0
papi 5.0.1 5.2.0
perftools 6.0.1 6.1.3
pgi 13.7.0 13.10.0
stat 1.2.1.3 2.0.0.1
xt-asyncp 5.17 5.24
xt-libsci 12.0.00 12.1.3

Additionally, several modules do not have default versions set currently. The default versions of those modules have been set as follows:

cray-ccdb/1.0.0 cray-netcdf-hdf5parallel/4.3.0 cray-netcdf/4.3.0
cray-parallel-netcdf/1.3.1.1 hdf5-parallel/1.8.11 intel/13.1.3.192
libfast/1.0.9 mrnet/3.0.0 ntk/1.5.0
parallel-netcdf/1.3.1 perftools-lite/6.1.3

NOTE: Many of the new default modules (including gcc, cray-libsci, cray-petsc, cray-tpsl, and cray-trilinos) have been built against mpich/6, which is based on MPICH 3.0.3 and is binary-incompatible with previous versions of the mpich module. Binaries should not be built using a mixture of mpich/5 and mpich/6 libraries.